Lord of the Rings Online’s server woes continue

    
40

Days after Lord of the Rings Online moved to its new datacenter, the game is still being plagued by server issues that is causing it to be unplayable for some.

One player reports why she’s unsubscribed from the game: “Bad lag, bad rubberbanding, missing housing items, house doesn’t show ownership, loss of friend lists, loss of connection to chat servers, connectivity issues, etc.”

Turbine disabled Paypal yesterday for the time being and has been asking players to provide feedback related to all of these issues as it continues to investigate the problem.

newest oldest most liked
Subscribe to:
Geering
Guest
Geering

Well, no one can connect now…

Don’t screw this up, Turbine. Not now! Not when we are so close to the end…

Covenant_U
Guest
Covenant_U

JimGriffiths Covenant_U Really?  Years?  And now tech issues with a datacenter move is the last straw?  Yet here you are, still bitching…

JimGriffiths
Guest
JimGriffiths

Covenant_U Don’t make Master Chief shoot you. The pitchforks have been out for years the current issues are just another rung on the ladder of many issues.

Dreema
Guest
Dreema

Day 5 of lag issues continue. Terrible unplayable lag on days 1 and 2, day 3 saw me disconnected several times, day 4 had me killed by mobs I couldn’t even see due to painful lag and day 5 so far has been… an improvement. Still lagging, still riding around on an invisible horse most of the time and instant cast spells often take 2-3 seconds to cast but better than it has been.

Covenant_U
Guest
Covenant_U

It’s a great game. So they are having some technical problems.  No lives have been lost.  It will get made right and you’ll be playing again soon.  Step away from the pitchforks…

Geering
Guest
Geering

In the last couple of hours, I have been getting some damn smooth performance in Evernight, with some of the best FPS I ever had in Bree & no lag/stuttering/rubberbanding at all, while earlier this afternoon, I was killed by lag in Bree – I died just in front of the Dwarf statue, no joke.

Minas Tirith still dips below 30 fps, but it seems smooth as well.

MAYBE they fixed it? Here’s hoping. We are too damn close to the end of the story for a tragedy to strike Turbine now.

Rebel Engie
Guest
Rebel Engie

BTW, otherwise I did not experience any problems, apart from the noticeable lagspikes since the upgrade and the occasional “Error 0x00000E” when moving items around the Bank (never lost anything).

Rebel Engie
Guest
Rebel Engie

Being unable to log in is very reminiscent of a recurring problem when I get disconnected (local internet issues) and then when trying to log back in on the same character, the connection process just stays on the Loading screen forever.
Later when eventually it does log in, ALL the chat channels are “Error 0x000000E” or “chat unavalaible.
This has been a problem for years, but they never fixed it.

Rebel Engie
Guest
Rebel Engie

mmonerd
These changes were supposed to bring the remaining playerbase together, and give them better hardware to play on.

MesaSage
Guest
MesaSage